Video Not Playing In Chrome - Solution

In recent weeks, due to new updates released for the Google Chrome Browser we have noticed an increase in support tickets in relation to the video player simply not appearing.
Upon investigation, we have discovered that the new Google update for Chrome causes the browser to force it to load pages as HTTPS (secure content only) rather than standard HTTP.
This means it looks at the eTV video player as 'non secure' and will not let it through. The player is safe and so is the content. There is just an easy fix for this as follows.

1. Open up any video page in eTV.

2. Once the page is loaded and the video player does not appear, look at the address bar at the top of the page and on the left hand side you should see it start with HTTPS. On the right, a small grey whiled should appear in the address bar.

3. Click on this small grey shield and a box will pop out asking if you wish to allow non-secure content through. Answer this question in the affirmative, yes and then ETV will be saved as a recognized provider in your browser settings and allow the video to play.

This issue does not fall within of our control and to encrypt all our videos to deliver in HTTPS is not a viable option for eTV.

We do stress once again that our content is safe, virus free, and will not harm your computer in any way.

We hope this will help should you see this issue. 

Useful links to this topic

https://support.google.com/chrome/answer/1342714?hl=en 

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk